const regex = /(?<=[\s][\d])(.*?)(?=[\d])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[\\s][\\d])(.*?)(?=[\\d])', 'gm')
const str = `blah xzuyguhbc ibcbb bqw 2 extract1 ☺️ jbjhcb 6 extract2 ? bjvcvvv
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}