re = /(?<=[\s][\d])(.*?)(?=[\d])/m
str = 'blah xzuyguhbc ibcbb bqw 2 extract1 ☺️ jbjhcb 6 extract2 ? bjvcvvv
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end