$re = '/(?<=[\s][\d])(.*?)(?=[\d])/m';
$str = 'blah xzuyguhbc ibcbb bqw 2 extract1 ☺️ jbjhcb 6 extract2 ? bjvcvvv
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);