using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"hello.*(?=hello)";
string input = @"hello i am xyz lol hello i
am abc ..;sda<>
hello
i am pqr ahe kiop hello
abc axyz
no
yes
hepdd
jol
hello
podjkd
dasfh";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}