import re
regex = re.compile(r"hello.*(?=hello)")
test_str = ("hello i am xyz lol hello i\n"
"am abc ..;sda<>\n"
"hello\n"
"i am pqr ahe kiop hello\n"
"abc axyz\n"
"no\n"
"yes \n"
"hepdd\n"
"jol\n"
"hello\n"
"podjkd\n"
"dasfh")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")