const regex = /hello.*(?=hello)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('hello.*(?=hello)', '')
const str = `hello i am xyz lol hello i
am abc ..;sda<>
hello
i am pqr ahe kiop hello
abc axyz
no
yes
hepdd
jol
hello
podjkd
dasfh`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}