import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "hello.*(?=hello)";
final String string = "hello i am xyz lol hello i\n"
+ "am abc ..;sda<>\n"
+ "hello\n"
+ "i am pqr ahe kiop hello\n"
+ "abc axyz\n"
+ "no\n"
+ "yes \n"
+ "hepdd\n"
+ "jol\n"
+ "hello\n"
+ "podjkd\n"
+ "dasfh";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}