# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=[^()]*\)[\w\s.,]*")-/./gm;t' <<< "-\"$(vc-alert)\"-$(vc-alert)-\"$(vc-alert)\"
-\"$(vc-alert-error)\"-$(vc-alert-error)-\"$(vc-alert-error)\"
-\"$(vc-alert-error_message)\"-$(vc-alert-error_message)-
\"This is a $(vc-alert-error) message.\""