import Foundation
let pattern = #"(?=[^()]*\)[\w\s.,]*")-"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
-"$(vc-alert)"-$(vc-alert)-"$(vc-alert)"
-"$(vc-alert-error)"-$(vc-alert-error)-"$(vc-alert-error)"
-"$(vc-alert-error_message)"-$(vc-alert-error_message)-
"This is a $(vc-alert-error) message."
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"."#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)