const regex = /(?=[^()]*\)[\w\s.,]*")-/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=[^()]*\\)[\\w\\s.,]*")-', 'gm')
const str = `-"\$(vc-alert)"-\$(vc-alert)-"\$(vc-alert)"
-"\$(vc-alert-error)"-\$(vc-alert-error)-"\$(vc-alert-error)"
-"\$(vc-alert-error_message)"-\$(vc-alert-error_message)-
"This is a \$(vc-alert-error) message."`;
const subst = `.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);