package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^CTR`)
var str = `CTRasdkljfhalksjdfhalksjdfhalskjhf
2f3232rjfkalkj23f2a523gap289gaCTR
23rCTRCTRs;flkjs;ldfjkCTR
CTR23dfhalskjhf
CTRasdkljfhalksjd234251dfhalskjhf
CTRasdkljf3623462346jdfhalskjhf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}