// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^CTR").unwrap();
let string = "CTRasdkljfhalksjdfhalksjdfhalskjhf
2f3232rjfkalkj23f2a523gap289gaCTR
23rCTRCTRs;flkjs;ldfjkCTR
CTR23dfhalskjhf
CTRasdkljfhalksjd234251dfhalskjhf
CTRasdkljf3623462346jdfhalskjhf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}