use strict;
my $str = 'CTRasdkljfhalksjdfhalksjdfhalskjhf
2f3232rjfkalkj23f2a523gap289gaCTR
23rCTRCTRs;flkjs;ldfjkCTR
CTR23dfhalskjhf
CTRasdkljfhalksjd234251dfhalskjhf
CTRasdkljf3623462346jdfhalskjhf';
my $regex = qr/^CTR/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}