# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\/(\w+[[\/])/\/:\1/g;t' <<< "//party[@id='party1:abc']/abc:person[@id='Trader']/trade/abc:personId[@personIdScheme='urn:xyz:person-id:PEOPLESOFT']/text()"