#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "/(\w+[[/])"
Local $sString = "//party[@id='party1:abc']/abc:person[@id='Trader']/trade/abc:personId[@personIdScheme='urn:xyz:person-id:PEOPLESOFT']/text()"
Local $sSubst = "/:\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)