import re
regex = re.compile(r"/(\w+[[/])")
test_str = "//party[@id='party1:abc']/abc:person[@id='Trader']/trade/abc:personId[@personIdScheme='urn:xyz:person-id:PEOPLESOFT']/text()"
subst = "/:\\1"
result = regex.sub(subst, test_str)
if result:
print(result)