use strict;
my $str = '//party[@id=\'party1:abc\']/abc:person[@id=\'Trader\']/trade/abc:personId[@personIdScheme=\'urn:xyz:person-id:PEOPLESOFT\']/text()';
my $regex = qr//(\w+[[/])/p;
my $subst = '/:\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";