using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+) ((\w+[ ,])+ ){2} (\d){5}";
string input = @"312 S McDaniel St Enfield NC 27823
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}