const regex = /(\d+) ((\w+[ ,])+ ){2} (\d){5}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+) ((\\w+[ ,])+ ){2} (\\d){5}', '')
const str = `312 S McDaniel St Enfield NC 27823
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}