$re = '/(\d+) ((\w+[ ,])+ ){2} (\d){5}/';
$str = '312 S McDaniel St Enfield NC 27823
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);