package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+) ((\w+[ ,])+ ){2} (\d){5}`)
var str = `312 S McDaniel St Enfield NC 27823
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}