package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{6}(?:\d{2})?(?:md?|dm?)?$`)
var str = `121212
12121212
121212d
121212md`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}