$re = '/^\d{6}(?:\d{2})?(?:md?|dm?)?$/m';
$str = '121212
12121212
121212d
121212md';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);