const regex = /^\d{6}(?:\d{2})?(?:md?|dm?)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{6}(?:\\d{2})?(?:md?|dm?)?$', 'gm')
const str = `121212
12121212
121212d
121212md`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}