import re
regex = re.compile(r"^\d{6}(?:\d{2})?(?:md?|dm?)?$", flags=re.MULTILINE)
test_str = ("121212\n"
"12121212\n"
"121212d\n"
"121212md")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")