#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)\d+(?=[^\d]*$)"
Local $sString = "data[KPI][0][rows][0][name]" & @CRLF & _
"data[KPI][0][rows][1][name]" & @CRLF & _
"data[KPI][0][rows][2][name]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)