$re = '/\d+(?=[^\d]*$)/im';
$str = 'data[KPI][0][rows][0][name]
data[KPI][0][rows][1][name]
data[KPI][0][rows][2][name]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;