re = /\d+(?=[^\d]*$)/im
str = 'data[KPI][0][rows][0][name]
data[KPI][0][rows][1][name]
data[KPI][0][rows][2][name]'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result