const regex = /\d+(?=[^\d]*$)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+(?=[^\\d]*$)', 'gim')
const str = `data[KPI][0][rows][0][name]
data[KPI][0][rows][1][name]
data[KPI][0][rows][2][name]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);