#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^ABD_DEF_GHIJ(?!_FX)"
Local $sString = "ABD_DEF_GHIJ_20150611" & @CRLF & _
"ABD_DEF_GHIJ" & @CRLF & _
"ABD_DEF_GHIJ_FX_20150611" & @CRLF & _
"ABD_DEF_GHIJ_FX"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")