import re
regex = re.compile(r"^ABD_DEF_GHIJ(?!_FX)", flags=re.MULTILINE)
test_str = ("ABD_DEF_GHIJ_20150611\n"
"ABD_DEF_GHIJ\n"
"ABD_DEF_GHIJ_FX_20150611\n"
"ABD_DEF_GHIJ_FX")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")