re = /^ABD_DEF_GHIJ(?!_FX)/m
str = 'ABD_DEF_GHIJ_20150611
ABD_DEF_GHIJ
ABD_DEF_GHIJ_FX_20150611
ABD_DEF_GHIJ_FX'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end