$re = '/^ABD_DEF_GHIJ(?!_FX)/m';
$str = 'ABD_DEF_GHIJ_20150611
ABD_DEF_GHIJ
ABD_DEF_GHIJ_FX_20150611
ABD_DEF_GHIJ_FX';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);