import re
regex = re.compile(r"(?!\d*[ -]\d)[^\d][+-]?\d*([.,]\d*)?(?<!-)(?!\d*[ -]\d)", flags=re.IGNORECASE)
test_str = ("23 34 56 78 90\n"
"23-34-56-78-90\n"
"23-34\n"
"23.2\n"
"+2.1\n"
"-3.3434\n"
"433,55")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")