re = /(?!\d*[ -]\d)[^\d][+-]?\d*([.,]\d*)?(?<!-)(?!\d*[ -]\d)/i
str = '23 34 56 78 90
23-34-56-78-90
23-34
23.2
+2.1
-3.3434
433,55'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end