# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<(\\/?)(p|h1)>/<$1$2>/g;t' <<< "<p>TEXT</p>"