const regex = /<(\/?)(p|h1)>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(\\\/?)(p|h1)>', 'g')
const str = `<p>TEXT</p>`;
const subst = `<$1$2>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);