#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w0-1P(?:([\w-])(?!(-)\1{1}))*$"
Local $sString = "R0-1P-10-8--F--YH-" & @CRLF & _
"10-1P-3E-Q-" & @CRLF & _
"[\w-]*(-)\1{1}" & @CRLF & _
"D0-1P" & @CRLF & _
"D0-1P-"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")