using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\w0-1P(?:([\w-])(?!(-)\1{1}))*$";
string input = @"R0-1P-10-8--F--YH-
10-1P-3E-Q-
[\w-]*(-)\1{1}
D0-1P
D0-1P-";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}