$re = '/^\w0-1P(?:([\w-])(?!(-)\1{1}))*$/m';
$str = 'R0-1P-10-8--F--YH-
10-1P-3E-Q-
[\\w-]*(-)\\1{1}
D0-1P
D0-1P-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);