const regex = /^\w0-1P(?:([\w-])(?!(-)\1{1}))*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\w0-1P(?:([\\w-])(?!(-)\\1{1}))*$', 'gm')
const str = `R0-1P-10-8--F--YH-
10-1P-3E-Q-
[\\w-]*(-)\\1{1}
D0-1P
D0-1P-`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}