using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img(.+)src=[\'""](.+?)[\'""](.*?)\>";
string input = @"<div align=""center""><img src=""media/k2/local/594b89d436f4b.jpeg"" border=""0"" alt="" /><br /><br /><img src=""media/k2/local/594b89d59fe0b.jpeg"" border=""0"" alt="" /><br /><br /><img src=""media/k2/local/594b89d68659f.jpeg"" border=""0"" alt="" /><br /><br /><img src=""media/k2/local/594b89d7289b6.jpeg"" border=""0"" alt="" /><br /><br /><img src=""media/k2/local/594b89d7cc2db.jpeg"" border=""0"" alt="" /><br /><br /><img src=""media/k2/local/594b89d8e3c3d.jpeg"" border=""0"" alt="" /><br /><br /><img src=""media/k2/local/594b89d9c732d.jpeg"" border=""0"" alt="" /></div>
<img src=""media/k2/local/594b89d436f4b.jpeg"" border=""0"" alt="" />
<img src=""media/k2/local/2.jpeg"" border=""0"" alt="" />";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}