import re
regex = re.compile(r"<img(.+)src=[\'\"](.+?)[\'\"](.*?)\>")
test_str = ("<div align=\"center\"><img src=\"media/k2/local/594b89d436f4b.jpeg\" border=\"0\" alt=\"\" /><br /><br /><img src=\"media/k2/local/594b89d59fe0b.jpeg\" border=\"0\" alt=\"\" /><br /><br /><img src=\"media/k2/local/594b89d68659f.jpeg\" border=\"0\" alt=\"\" /><br /><br /><img src=\"media/k2/local/594b89d7289b6.jpeg\" border=\"0\" alt=\"\" /><br /><br /><img src=\"media/k2/local/594b89d7cc2db.jpeg\" border=\"0\" alt=\"\" /><br /><br /><img src=\"media/k2/local/594b89d8e3c3d.jpeg\" border=\"0\" alt=\"\" /><br /><br /><img src=\"media/k2/local/594b89d9c732d.jpeg\" border=\"0\" alt=\"\" /></div>\n\n"
"<img src=\"media/k2/local/594b89d436f4b.jpeg\" border=\"0\" alt=\"\" />\n\n"
"<img src=\"media/k2/local/2.jpeg\" border=\"0\" alt=\"\" />")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")