// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<img(.+)src=[\'"](.+?)[\'"](.*?)\>"#).unwrap();
let string = "<div align=\"center\"><img src=\"media/k2/local/594b89d436f4b.jpeg\" border=\"0\" alt=\"\" /><br /><br /><img src=\"media/k2/local/594b89d59fe0b.jpeg\" border=\"0\" alt=\"\" /><br /><br /><img src=\"media/k2/local/594b89d68659f.jpeg\" border=\"0\" alt=\"\" /><br /><br /><img src=\"media/k2/local/594b89d7289b6.jpeg\" border=\"0\" alt=\"\" /><br /><br /><img src=\"media/k2/local/594b89d7cc2db.jpeg\" border=\"0\" alt=\"\" /><br /><br /><img src=\"media/k2/local/594b89d8e3c3d.jpeg\" border=\"0\" alt=\"\" /><br /><br /><img src=\"media/k2/local/594b89d9c732d.jpeg\" border=\"0\" alt=\"\" /></div>
<img src=\"media/k2/local/594b89d436f4b.jpeg\" border=\"0\" alt=\"\" />
<img src=\"media/k2/local/2.jpeg\" border=\"0\" alt=\"\" />";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}