use strict;
my $str = '<div align="center"><img src="media/k2/local/594b89d436f4b.jpeg" border="0" alt="" /><br /><br /><img src="media/k2/local/594b89d59fe0b.jpeg" border="0" alt="" /><br /><br /><img src="media/k2/local/594b89d68659f.jpeg" border="0" alt="" /><br /><br /><img src="media/k2/local/594b89d7289b6.jpeg" border="0" alt="" /><br /><br /><img src="media/k2/local/594b89d7cc2db.jpeg" border="0" alt="" /><br /><br /><img src="media/k2/local/594b89d8e3c3d.jpeg" border="0" alt="" /><br /><br /><img src="media/k2/local/594b89d9c732d.jpeg" border="0" alt="" /></div>
<img src="media/k2/local/594b89d436f4b.jpeg" border="0" alt="" />
<img src="media/k2/local/2.jpeg" border="0" alt="" />';
my $regex = qr/<img(.+)src=[\'"](.+?)[\'"](.*?)\>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}