import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\\"|\\G) *\\K\\w+(?=.*\\\")|(?:\\'|\\G) *\\K\\w+(?=.*\\')";
final String string = "\"string_1\"\n"
+ "'string_2'\n"
+ "try this one: \"string_3 string4\" it seems OK\n"
+ "'string_5 string6' \n"
+ "\"string_7 string8 string9\"\n"
+ "\"string_10'\n"
+ "'string_11'\n\n"
+ "\"string_1\"\n"
+ "'string_1'\n"
+ "\"string_1 string2\"\n"
+ "'string_1 string2'\n"
+ "\"string_1 string2 string3\"\n"
+ "$string_1;\n"
+ "//string_1\n"
+ "string_1=\"\n"
+ "\"$string_1\n"
+ "//string_1\n"
+ "string_1\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}