const regex = /(?:\"|\G) *\K\w+(?=.*\")|(?:\'|\G) *\K\w+(?=.*\')/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\"|\\G) *\\K\\w+(?=.*\\")|(?:\\\'|\\G) *\\K\\w+(?=.*\\\')', 'gm')
const str = `"string_1"
'string_2'
try this one: "string_3 string4" it seems OK
'string_5 string6'
"string_7 string8 string9"
"string_10'
'string_11'
"string_1"
'string_1'
"string_1 string2"
'string_1 string2'
"string_1 string2 string3"
\$string_1;
//string_1
string_1="
"\$string_1
//string_1
string_1"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}