import re
regex = re.compile(r"(?:\"|\G) *\K\w+(?=.*\")|(?:\'|\G) *\K\w+(?=.*\')", flags=re.MULTILINE)
test_str = ("\"string_1\"\n"
"'string_2'\n"
"try this one: \"string_3 string4\" it seems OK\n"
"'string_5 string6' \n"
"\"string_7 string8 string9\"\n"
"\"string_10'\n"
"'string_11'\n\n"
"\"string_1\"\n"
"'string_1'\n"
"\"string_1 string2\"\n"
"'string_1 string2'\n"
"\"string_1 string2 string3\"\n"
"$string_1;\n"
"//string_1\n"
"string_1=\"\n"
"\"$string_1\n"
"//string_1\n"
"string_1\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")