$re = '/(?:\"|\G) *\K\w+(?=.*\")|(?:\'|\G) *\K\w+(?=.*\')/m';
$str = '"string_1"
\'string_2\'
try this one: "string_3 string4" it seems OK
\'string_5 string6\'
"string_7 string8 string9"
"string_10\'
\'string_11\'
"string_1"
\'string_1\'
"string_1 string2"
\'string_1 string2\'
"string_1 string2 string3"
$string_1;
//string_1
string_1="
"$string_1
//string_1
string_1"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);