package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(Apple2\b.*)$`)
var str = `Apple1:Banana1:Pear1
Apple2:Banana2:Pear2
Apple3:Banana3:Pear3
Apple22:Apple24:Pear2
Apple2s:Apple24:Pear2
Apple22:Apple2:Pear2
Apple22:Apple2:Pear2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}